File Menu
The file menu contains a variety of commands, settings and options for WeConfig. It is divided into three submenus, File, Edit and Help:
File
The File menu contains commands related to project management, application settings, and exiting the application. It has the following commands:
| Command | Hotkey | Explanation |
|---|---|---|
| New | Ctrl-N | Creates a new, empty project |
| Open | Ctrl-O | Opens an existing project from the file system |
| Recent Projects | Shows a list of recently opened projects, clicking a project opens it | |
| Save | Ctrl-S | Saves the currently open project, requesting a save location if needed |
| Save As | Ctrl-Shift-S | Saves the currently open project, always requests a save location |
| About | Navigates to the about menu. | |
| Exit | Alt-F4 | Exits WeConfig |
Edit
The Edit menu contains commands related to editing the current project or its contents. It has the following commands:
| Command | Hotkey | Explanation |
|---|---|---|
| Create portable installation | Generate a portable installation of WeConfig | |
| Settings | Navigates to the application settings menu. |
Help
The Help menu contains commands related to obtaining help and information about WeConfig. It has the following commands:
| Command | Hotkey | Explanation |
|---|---|---|
| User's Guide | Opens this user guide | |
| Support file | Creates a support file to help developers identify the source of encountered issues | |
| Reset Layout | Restores the document panel to a default, empty state. |